Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Issue: You're Offline - Try to disable and renable your network connection.

Im using a Mac with big sur and and the checker plus pop up appears blank with message: You're Offline - Try to disable and renable your network connection.

Already tried uninstalling, algo, doesnt display unread count (screenshot attached)



  • Have you tried the instructions to disable and renable your network connection?

    Can you also tell me if this page says you are "connected or not"


  • It worked by shutting down the network and the sign in in again, thanks!!!

  • Same issue here, the page says "Not connected". Disabled Wi-fi, reinstalled extension...

  • @Nikola Smiljanić My extension does not contain the words "Not connected" can you send me a screenshot of this error?

  • I was referring to the link you sent in the earlier message.

  • @Nikola Smiljanić ah i understand, so this means the issue lies with os/browser itself having difficulty with the connection status, try reseting any Chrome flags,or disabling other extensions or VPN etc and obviously restart everything also.

  • That fixed it, thanks.

  • @Nikola Smiljanić Just for reference can you specify which step you think resolved it?

  • Restarting Chrome. Thanks for quick help!

  • I am struggling with this same issue. I have reset Checker and re-logged in, disabled wifi, reset ethernet connection, reinstalled extention, reset Chrome flags, disabled other extentions... still no luck.

    http://jsfiddle.net/DerekL/fHQK4/ - page says I'm not connected.

  • edited April 2022

    @StefenieColyer Did you try restarting the computer, as long as that test script on jsfiddle is also returning not connected, than this issue is not related to my specific extension, but rather a browser, software or system issue.

  • Same issue here with the extension in the latest version of Chrome on new iMac. Was perfectly running on windows.

    When using the browser you can go to any website you want and the extension keeps the same message (you are offline etc.). I tried to turn off/on the extension but that's when i quit Chrome and reopen it that the extension works again

    Sounds like OS related issue as i never had pb until i switched last week from Windows to Mac (both are on the same network, located at the same place, with the same signal strengh)

    Thanks for the extension and support

  • @pihomeserver have you changed ant Chrome flags?

    If you use the fiddle link above does it display "connected"?

  • I'm encountering the same problem. When I reboot my network, the problem gets fixed, but then it becomes inaccessible again after some time. I've also tried uninstalling the plugin, restarting my computer, restarting my browser and other similar steps, but none of them worked. Every time, I can only fix the problem by rebooting my network, but then it becomes inaccessible again after some time. I've also tried turning off the firewall and disabling security software, but it didn't work. However, when I use the plugin on other computers, there is no problem. My system is Win 11 22H2.

  • @JayJoe Have you tried with different browsers? like Chrome?

    Although I admit it's looking like a system issue as you have already identified.

  • @Jason Yes, it looks like a system issue. I have tried both Edge and Chrome browsers on this computer and the problem persists. I have also tried connecting to both my company's network and my home network and the problem remains. This issue has not occurred on any of my other PCs and the only fix I know of currently is to restart the network. If it is truly a system-related issue, do you have any suggestions for troubleshooting methods?

  • At this moment, both of these plugins are not working.

  • @JayJoe It appears to be a Chrome / Edge bug: https://bugs.chromium.org/p/chromium/issues/detail?id=678075

    Have you tried in Firefox?

    I am planning a workaround for this issue in my next extension updates to disable the "online" check.

  • @Jason That's great and TKS. I also noticed a phenomenon, although it shows offline, I can still receive emails normally and events can also be added normally in the calendar. In other words, only the icon is gray and it shows offline, but it does not affect normal use.

  • @JayJoe Yes thanks, the ticket indicated that also. Note the ticket also indicated possibly just turning off/on the wifi could temporarily work instead of the network adapter.

    What's the frequency of the issue?

  • @Jason The frequency is still quite high. Generally, when I find that the icon has turned gray, I'll turn off the wifi and then turn it back on. It may not take long for the icon to turn gray again. If I don't do anything, it will never recover. If I keep restarting the wifi, I feel like it could happen a dozen times in a day.

  • @Jason hi Jason,any plan for this issue? Looking forward to your reply.

  • @JayJoe So I just released an update for my Gmail extension 23.6 with the Options .. Admin .. Disable is online check. Can you force the Gmail extension update and enable that option: https://jasonsavard.com/wiki/Extension_Updates

  • @JayJoe Oops, I just realized there is a bug with that new option :(

    But you can manually diable the check by going to the background page and executing the line below: https://jasonsavard.com/wiki/Error_logs

    storage.set("disableOnline", true);

  • @Jason I'm sorry, I didn't quite understand how to operate the backend settings(storage.set("disableOnline", true);). Could you please describe it in more detail?

  • @JayJoe So you have the option of waiting for my next update to fix this again or you can try this:

    1. Click the Chrome menu icon > More tools > Extensions
    2. Select Developer mode at the top right
    3. Find the extension and click the service worker/background link
    4. Select the Console tab
    5. execute this line below:
    6. storage.set("disableOnline", true);

  • @Jason I have followed the steps, but it's not working. I will wait for your next update. Thank you very much.

  • @JayJoe Did your restart the browser after?

  • @Jason Yes, I restarted the browser, but it's not working.

  • @JayJoe Ok I pushed another update to the extension v23.6.0.1

    You can force the update with: https://jasonsavard.com/wiki/Extension_Updates

    Then enable this option:

This website uses cookies to ensure you get the best experience on our website. More info
Got it!