Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

"Error: jerror with sync deferreds" when saving backup

Well, the title says it all: I try to "Save Options" on the ADMIN tab, but I get the error "Error: jerror with sync deferreds".

Great plug-in BTW! Thanks.


  • Can you do that save again and then right click anywhere in the options page > Inspect > Console tab > and send me the logs.

  • edited January 2020

    here it is

  • hmm, looks like I forgot to spit out the root cause error in the logs :(

    which version of the extension are you using?

    have you added custom sounds or can think of any customization that might have broken the sync?

    lastly I might have you reinstall the extension and try the save again

  • I have V.22.0. It actually just got updated, together with Chrome, and when I restarted Chrome, it said "Corrupt Chrome profile" initially. Then I restarted the computer and it worked, but I can't save the configuration.

    The problem is that I don't want to lose the configuration and the accounts in Checker, so I would very much prefer if I don't reinstall the plugin and risk losing what I have already saved there. I haven't actually changed anything in the settings for a long time, and have backed up successfully before, so that should not be a problem.

    Which brings me to an additional question or request: Could you also add an option to save the settings and accounts as a file, in case the cloud backup doesn't work? I had an issue about a year ago when Checker got updated and somehow wouldn't restore the online backup, so I had to configure everything from scratch. So I think having an alternative backup option as a file to export and import would be very helpful.

  • edited January 2020

    Hmm the corrupt profile is probably the underlying issue to the sync, this generally is not recoverable unfortunately - more info https://jasonsavard.com/wiki/Corrupt_browser_profile.

    In the next update I will be expanding the logs to determine the root cause of the sync error. You can wait for the update, but it's not going in for a couple of weeks - as I have another update going through.

    Note also that the issue here would be not resolved with the file backup method as it is the extension data itself which is possibly corrupted. These are all guesses until I get more detailed logs.

  • Sorry for the delay.

    OK then, I'll wait for the update and hopefully we can find then.

    The file export would still be helpful though. It would store all configuration and log-in data (because I use the stay signed-in feature, not the auto-detect one), and then independently of whether the file has been saved on the cloud, we would always have the file as alternative.

    I say this because for instance, now that the extension data or browser profile is corrupted, I also tried restoring the backup data onto another laptop and freshly installed browser, and it would not restore them. I had backed up the configuration earlier when it was working. So apparently the cloud backup is also corrupted and I cannot restore it regardless of whether I reset the browser and plug-in. So this is where the exported file would come in handy.

  • Same here on v. ?

  • edited March 2020

    @Florian Schmoll ok thanks for the screenshot, i'll lower the bytes per item in the yet another update in v22.0.2.4 to fix this issue.

  • thanks for your great work! ??

  • I too am getting this 'Error: jerror with sync deferreds: sync error: QUOTA_BYTES_PER_ITEM quota exceeded' error since the last Chrome update on my Chromebook.

    I have 2 profiles on my Chromebook (self and one for wife). I also installed the Gmail Checker on my wife's profile and hers still backs up without an issue. I log her out and log back into my profile on the Chromebook and I get the error message. I use stan alone Chrome on the PC and I get the error as well, so I assume it's directly related to my Chrome Profile.

    Given this is the situation I'm experiencing, would an uninstall/reinstall of Gmail Checker fix it? Google Calendar Checker is unaffected.

  • @John Crossley thanks for the details, refer to my last comment above, you'll have to wait till i push that version to the chrome store before attempting a reinstal, it takes a while for the chrome team to approve updates.

  • No worries. As always, thanks for the great support Jason.

  • Keep us updated when the update is pushed.

  • @Florian Schmoll @ThuWin I pushed out v22.0.2.5, let me know if it resolved the issue - you'll probably have to reinstall to force the udpate.

  • @James Georgeson I think it's working.

  • @Jason I already updated the extension manually in developer mode last night. Coincidentally, I was setting up your extension for a friend and discovered that he had a newer version than I did. ?

    The issue seems to be fixed in  v22.0.2.5. Great job! ??

  • Good morning

    I updated to v22.0.2.7 and I'm still experiencing the error.

    I have to remove and re-install the extension?

    Thank you

  • edited March 2020

    @Carlo Queirolo Yes reinstalling the extension is the correct thing to do, after the update are you getting the error with "Save Options" in the ADMIN tab?

  • @Jason ok, I will do this.

    Thank you very much

  • Hey Jason, still getting the same error here. I uninstalled, rebooted Chromebook, reinstalled the app, tried restoring (it confirmed action but restored app was not what I had saved before these problems). Then redid the steps about up to the restore point and instead re configured the app from scratch after confirming 'already contributed'. Once that was done I again tried to save settings and got the 'sync error: QUOTA_BYTES_PER_ITEM quota exceeded' again.

    The app confirms as being version and I am running ChromeOS Version 80.0.3987.162 (Official Build) (64-bit).

    Are there any other details I can give you to help trouble shooting this?

  • edited April 2020

    I should also add Jason that all the other functions of the app that I use are still working flawlessly - it's just the SAVE function.

  • @John Crossley Ok i'll try reducing the quota again in the next update coming soon in v22.1

  • Cheers Jason - anything else you can think of me trying just sing out. A new config setup only takes me 5 minutes from scratch anyway.

  • Hi Jason. now running V22.1 of your app with ChromeOS version 81.0.4044.127 (Official Build) (64-bit). Issue is still occurring but I haven't uninstalled/reinstalled the app. Should I do this to hopefully let me backup/restore my settings again?


    John C.

  • @John Crossley Hmm so i've lowered it 3 times now, i'm wondering if this issue is system related as it looks like it was resolved for some in this thread.

    You can try some tests like reinstalling and just testing the save from the default settings.

  • No worries, I'll try that again.

    Just for information, I've usually got 3 Gmail accounts set up on the app (4 in the last few days) and I'm getting the issue on both the latest version of Chrome on a PC as well as the latest version of ChromeOS on my new Chromebook as well as on a 2015 model Chromebook which stopped receiving updates as a result of Googles EOL policy early last year. I've also bought the paid version of your app for my wife and she's using ot on all the same hardware and software versions I am without a problem. The only difference being that my Chrome runs a lot of apps/extensions whereas the wifes runs only a handful.

    I'll do an uninstall/reinstall again and see how I go & let you know.

    John C.

    PS Mate, everytime I message you morning, noon or night you answer straight away. You really need to get some sleep Jason ;)

  • @John Crossley So it appears it might be related to your profile, have you tried disabling some extensions? I'm sorry this response was an hour late ;) I was outside.

  • Ok, uninstalled and reinstalled and when I put in my primary gmail address on it's own, no problem - saves/restores fine. When I manually put in a 2nd or 3rd gmail address save/restore error returns.

    However, if I log into my various gmail accounts by opening a gmail tab and manually enter them by clicking my profile and add my various accounts there and then into your app config, change to AUTO DETECT SIGNED IN ACCOUNTS it then picks up ALL my the logged in accounts, lists them in your app and will SAVE/RESTORE no problem. If I manually deselect one of the AUTO DETECTED accounts it obviously removes it from YOUR APP when I open it, leaves it in the AUTO DETECTED menu (just with a line through it) and again SAVE/RESTORE all ok.

    SUMMARY: Hope this makes sense (it's very early here so eyes are still blurry). What I've established (for my setup) is that SAVE/RESTORE works no problem if I

    (A) just let your app AUTO DETECT accounts I have signed into via my profile in Gmail (regardless of how many I have listed in my Google Account) or

    (B) I manually enter the primary account via ADD ACCOUNTS it still SAVES/RESTORE ok. If I manually add 2 or more accounts the SAVE/RESTORE fails with the error we've been talking about.

    So, to get it working and looking like I've always had it in the past, I need to let AUTO DETECT do it's thing with all the Gmail accounts I've entered into my Gmail profile and just manually unclick the ones I don't want your app to display. (Probably a better way to do it in the first place anyway).

    Something has changed in either an update of your app or with a Chrome/ChromeOS update to make the ADD ACCOUNTS manually thing bork the SAVE/RESTORE but I can work around that as above just using the AUTO DETECT and logging into the Gmail accounts I need through my Gmail profile and desecting the ones I don't want to see in your apps UI. All good and the moons have realigned in my work. It's working how I like now so I wont try and fix it anymore.

    Thanks again Jason for the help. Stay outside mate, I hear fresh air and sunshine quickly kills the Corona-19 germs anyway so it's probably safer ;)

    Cheers. John C.

  • I just confirmed the same issue for me—I found this thread when trying to figure out why I was getting the same error with synced settings, and uninstalling/reinstalling did nothing (nor did attempting to clear chrome.storage.sync from the console), but it went away when I switched from “Add Accounts and stay signed in” to “Auto-detect signed in accounts”.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!