Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Error message when attempting a screenshot

ReferenceError: audioStream is not defined at chrome-extension://mdddabjhelpilpnpgondfmehhcplpiin/js/record-screen.js:286:13 at chrome-extension://mdddabjhelpilpnpgondfmehhcplpiin/js/record-screen.js:303:11


But not a audio stream, I am attempting a screen shot.


This is the screen from a linux utility



Comments

  • Ok thanks, there should be a record window that appears in the background when attempting to record, can you replicate this error again and then right click anywhere in that window, click Inspect and select the Console tab and send me the error logs.

  • I can't find this "record window" at all.

    Can you lay out the exact procedure t get this?

  • Ok let's see retrieve the error logs from the service worker instead, first reproduce the error then get the logs from here:

    https://jasonsavard.com/wiki/Error_logs

  • edited May 5

    No logs, Jason?? Need permission

  • So it you might need to allow the "screen recording" permission at the OS level, I know Mac users need to enable it in their system settings such as as this.

    Would you be able to locate something similar for Linux...


  • I guess this would do it? https://tinyurl.com/33k7agp6

    Start that before I attempt the screenshot?

  • No, that didn't work, just opened the generic screenshot utility.

  • Ok I pushed an update to get a better idea of the error, you can force the update to v15.0.3

    with this: https://jasonsavard.com/wiki/Extension_Updates

    Then reproduce the issue and let me know the error it displays

  • Lte here, probably tomorrow my time.

  • No record window, now new error.


  • Which screen selections below work and don't work?

    And are you still getting that "aw snap" crash page also?


  • I get the "aw Snap" page.


    I click on your icon in the Google Taskbar (right click doesn't work inside the page).


    I "Select Area".


    Immediately after that I get the "Invalid state" error screen.

  • edited May 8

    Hmm so after reviewing the code, when using the "Select area" it should not be executing the record-screen code & error that you initially reported above. So something very weird is going on.

    Did the extension ever work for you in the past?

    Have you tried reinstalling the extension?

    Do you have other extensions installed? that might be interfering.

  • Worked 100% prior, except from some pop up windows, which disappeared when I tried the extension.

    No new extensions installed for months & months now, in fact some were removed.

    You suggest a reinstall?

  • So yes I would suggest reinstalling the extension first.

    But I would also suggest temporarily disabling all other extensions to see if they are interrupting - as they do get updated automatically several times and can suddenly create issues.

  • Let me see if I can replicate in incognito mode.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!