Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact


I noticed that if I enter a birthday in Google Contacts, it shows in Google Calendar, but the same does not seem true for anniversaries entered in Google Contacts. Is this something that Checker Plus can do?


  • Is the birthday calendar selected in the extension, refer to this: https://jasonsavard.com/wiki/Visible_calendars_in_popup_window

  • Yes, birthday calendar is selected

  • Hmm I am seeing birthdays in my calendar, can you try double clicking the refresh button in the extension calendar window at the top right.

  • Yes, I have birthdays showing in my calendar too, I just don't see anniversaries.

  • Oh how are anniversaries different from birthdays? are they from the same calendar?

    Can you show me a screenshot from your Google Calendar of these anniversaries?

  • They are entered as an additional date in contacts

  • Ok didn't know about that field, but I just tested it and after refreshing, I also saw that anniversaries work show in my extension...

  • Ok, I looked more into it, and I see that I don't have an option in Checker Plus for Birthdays. Not sure why?

  • Ah so you are not seeing the Birthdays calendar listed, can you double click the refresh button in the calendar extension window.

  • Still doesn't show. It does show in Google Calendars, just missing in Checker Plus

  • I just rebooted, and that didn't help either.

  • Hmm let's try reinstalling the extension and see if that works.

  • Reinstalled the extension, same issue

  • So the Birthdays calendar is not listed in the extension?

    Can you show me a screenshot of this Birthday calendar from your Google Calendar website?

  • My apologies, it was in calendar settings, birthday was unchecked. It must have happened in error.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!