Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

was not working, now working again

I have two macbooks, and I log into chrome with the same user on each so my extensions sync. On one macbook Checker stopped working. Specifically, I could see my gmail accounts in the extension, but they were weren't getting notified and when I clicked on an account nothing happened. On the other macbook there were no issues with Checker. So, I tried uninstalling Checker on the bad macbook. I again saw all my gmail accounts, but still not working. Then, I uninstalled again and left it that way. Later, I was using the good macbook. Of course, Checker was gone since chrome syncs. I re-installed Checker on the good macbook, and Checker worked perfectly as before. Then, I opened my bad macbook. Chrome synced and Checker was back as it should be. However, now Checker worked perfectly on what was the bad macbook.

So, everything is good now, but I wanted to report this strange situation.


  • Thanks for the details, I'll keep the sync issue in mind for future debugging.

  • The issue has re-surfaced for me. Also, I noticed in the reviews that others have seen this too.

  • edited February 29

    Let's make the test simple, so we can determine the issue.

    Are you using auto-detect or manual add? https://jasonsavard.com/wiki/Account_sign_in_methods

    If you send yourself an email do you get a notification? and does it appear in the extension window?

  • Auto-detect.

    I do get a notification, and it does appear in the extension window. When I click on the extension window notification, it opens the gmail account in another Chrome tab.

    However, when I close the tab and try to re-open the gmail account again by clicking on the extension window this time without notifications, nothing happens. And that is the issue.

  • edited February 29

    So only when you have no Gmail tabs open - then it fails to open a new Gmail tab?

    Can you send me a video or screenshots so I understand the context and which buttons are being clicked.

  • Ok thanks for the clear video, can you disable all the other extensions and try again.

    and if it fails again can you send me the error logs: https://jasonsavard.com/wiki/Error_logs

  • Ok does the issue always happen when there are no emails under that account?

    If so let's try this test, right click the extension icon .. select "Inspect popup" and then go to the Console tab and copy/paste the text below and hit enter to execute it, let me know if it opens a Gmail tab.

    executeAccountAction(accounts[0], "openInbox", {actionParams: {}});

  • edited February 29

    Yes, only when there are no emails.

    When I run your javascript it does open a Gmail tab.

  • Ok I think we have the issue, it's a race condition, between opening Gmail and closing that popup window and it existed on Macs, but I can see it's also on Chromebooks, i'll be pushing out a fix soon.

    I'm curious does the same issue happen when try using the + button to open a Compose window? does it also fail to open.

  • The + button does nothing too.

    BTW, this issue happens on Sonoma OS but not Ventura OS.

  • Ok excellent we confirmed the bug, i'll notify you in a day when the fix is out. Thanks for all the debugging.

  • Thank you!

  • Ok version 25.0.11 is out with a possible fix, can you test it out by forcing the update with this: https://jasonsavard.com/wiki/Extension_Updates

  • Okay. I updated and so far so good. If I find anything I'll let you know. Thanks!

  • Great let me know if the compose + button works also.

  • Yup, it's working.

  • Getting new issues with Sonoma. Still, good with Ventura.

    I'm not offline. And when I click the plus I get

  • Can you try enabling the Options .. Admin .. Disable online check

  • That fixed both problems.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!