Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

[Bug?] Extension seems to be messing up system screen settings

Hi,

My screen has been acting very weird lately. It was so difficult to debug it that I chose to reinstall Windows from scratch (including apps and drivers). However, the issue persisted.

Turns out that, as soon as I disabled Checker Plus extensions (Gmail/Calendar), the issue disappeared.

Here's what's happening. My Windows is set to turn the monitor off after 10 minutes of inactivity - it doesn't sleep or shut down, however.

After it goes off, it stays like that for one minute or so. Then, it turns on for a few seconds and then goes off again. Then it loops. So my monitor is constantly on and off when I'm away from the PC. Sometimes I'm not even away, I'm just beside it doing something else.

It's like one of the extensions briefly wakes up the monitor for some reason - to check for new emails/events or something.

Here's a video: https://www.reddit.com/r/pchelp/comments/14cbwfv/help_this_is_what_my_monitor_has_been_doing/

Is there a fix for this? Has this issue even been logged yet?

Thanks.

Comments

  • It's quite possible the Gmail extension sends a notification when you have a new email. And the notification could wake up your computer depending on your OS settings, but you can try disabling that with your OS here are Windows instructions: https://answers.microsoft.com/en-us/windows/forum/all/how-to-prevent-notifications-to-wake-up-windows-11/cd21d0b1-c288-4ea7-a91b-90b46ac22994

  • I think the only way to circumvent this is by turning off notifications for Chrome on Windows 11. I'm still testing to see if it works. I'll report back.

    However, this seems to happen every number of seconds, and not only when I get email. It's as if the extension is running auto checks in the background.

    In the past, that didn't use to happen - this setting incompatibility. Would you be able to fix it, you think?

  • This is the first report of this behaviour so I'll keep a watch on it, but I haven't changed anything related to this so I can only assume a local environment configuration that is contributing.

  • Hmm, I'm not sure. I reinstalled Windows from scratch and updated all drivers. Also, I think most people have their screen sleep timer set to 'off', so they won't notice this behavior. I really wanted to keep the extension and this screen setting on.

    I don't understand much of coding but could there be a setting to check if Windows is in energy-saving mode? Once it's not, the extension could keep running its checks.

  • A test you can try is disabling the calendar extension and for the Gmail one just change the extension account ... polling time from 30 seconds to 10min.

  • Hey Jason! I'm testing it again today and... disabling the calendar extension has stopped the issue, while enabling/disabling the Gmail one hasn't made a difference.

    This is what I have for some of my calendar settings (screenshots attached).


  • Ok good tests, so we can playing with the calendar options, and essentially uncheck most things until, such as unchecking the notifications and also the show times on button. Because these run on a 1 minute interval.


  • Hi. I went to Notifications --> Desktop Notifications --> Off and it seems to have solved the problem. It used to be 'Rich Notification'.

    The setting 'Show time of event on button icon' didn't affect anything, apparently.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!