Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Popup notification is not working, but the sound is

I've followed all the steps from windows 10 to your app to chrome settings and still a no go. Would love for this to work. Will donate.

Sonny

sonnyvha@gmail.com

«1

Comments

  • Is the test notification in the options working?

  • Ok so that usually identifies an issue at the Chrome or OS level and not the extension level. You'll have to double check the Chrome / OS settings referenced in the link above. Did you also try reinstalling the extension.

  • Did all of that, windows update, rebooted, and reinstalled.

  • After clicking the test notification can you send me the logs https://jasonsavard.com/wiki/Error_logs

  • It's blank or I'm doing something wrong. I can do a screenshare if you can.


  • I think popup is not working is due to. I have "Do not show notifications if a Gmail tab is open"

  • Nope that was not it. Icon animation works fine, just no popup.

  • Hmm good guess given the logs.

    When you reinstall the extension can you make sure not to change any option and not load any previous settings - in otherwise leave the default options.

    Then perform the test notification.

  • ok let me try

  • ok uninstalled - rebooted - re-installed and did not change anything. Just enabled it. Waiting on a mail to come in.

  • So one easy trick is simply mark an email as unread in your Gmail website and then test the notification button.

  • Still not working

  • running this


    Get-AppxPackage | % { Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppxManifest.xml" -verbose }

  • In the extension background Console tab can you run this statement and let me know what it returns:


    chrome.notifications

  • ok good thanks,

    let's try this one and let me know if it opens up a notification:


    chrome.notifications.create({type:"basic", iconUrl:Icons.NOTIFICATION_ICON_URL, title:"test", message:"mymessage"})

  • Should this be on or off?

  • now I'm geting no sound and the popup is on windows botom right

  • Yes! That was step #2 from the original link I sent you...


    https://jasonsavard.com/wiki/Notifications_are_not_working


    "Windows users: Enable notifications and try turning it off and then on again: Start menu > Settings > System > Notifications and action settings > Get notifications from apps and other senders Make sure Google Chrome is also enabled below that option"


    Just for reference I need to understand why you may have missed that step or instruction.

  • ok, did both. Not sure why I missed it. sorry

  • ok giving up for now. I have to get ready.


    thank you for your help.

  • oh I thought that resolved it since you sent me a screenshot with a successful notification.

  • Hi, Jason, I'm facing the same issue here. macOS Big Sur Version 11.4. Chrome Version 91.0.4472.77 (Official Build) (x86_64).


    Try re-installing the extension before doing this list. - Done / Still not working

     

    Windows users: Enable notifications and try turning it off and then on again: Start menu > Settings > System > Notifications and action settings > Get notifications from apps and other senders Make sure Google Chrome is also enabled below that option (Note about double sounds) - Mac user

     

    Mac users: System preferences > Notifications > Google Chrome > Allow notifications from Google Chrome  - Done / Still not working

     

    Make sure Start menu > Settings > System > Focus Assist is off - Mac User

     

    Enable extension notifications: Options > Notifications > Desktop notifications - Set is rich notification

     

    Enable Start menu > Settings > Privacy > Background apps > Let apps run in background - Mac User

     

    Click the notification icon beside the Notifications option. Does that work?  - Done / Is not working (nothing happens)

     

    When you get a new email does the button shake? Yes.

     

    Try signing out and back in to your Google accounts.  - Done / Still not working

     

    Try restarting the computer (Yes this has worked for some people :)  - Done / Still not working

     

    Remove the Option > Notifications > Do not show notification if you're already in your Gmail tab  - Done / Still not working

     

    Are you monitoring the correct labels in Options > Accounts/Labels  - Done / Yes and Still not working

     

    Is the checkbox to the right of each monitored label under the heading "Notification" also checked? - Done / I don't see any monitored label option under "Notification"

     

    Generally, new emails should show a notification AND they will appear in the popup window when you click the button at the top, are the emails appearing there? Done. No

  • @Leandro Segalla I'm going to revisit your last answer: are the unread emails showing in the top popup window when you click the mail icon button at the top?

This website uses cookies to ensure you get the best experience on our website. More info
Got it!