Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Popup is way too large when using "Autosize popup" option with KDE Plasma Wayland

Hello Jason!

I am experiencing the following issue: the popup window is much larger than needed.

I have the option "Autosize popup windows" enabled.

I am using display scale from KDE settings set to 125% on a 1920x1080 pixel display.

Operating System: Kubuntu 21.04

KDE Plasma Version: 5.21.4

KDE Frameworks Version: 5.80.0

Qt Version: 5.15.2

Kernel Version: 5.11.0-17-generic

OS Type: 64-bit

Graphics Platform: Wayland

Graphics Processor: Mesa Intel® UHD Graphics 620


  • Did you try also not checking the autosize option?

    Most likely it's related to that 125% setting.

    Does the issue happen with Chrome also?

  • Hi Jason!

    The issue appears when the option "Autosize popup windows" is enabled on a platform that uses a Wayland compositor session and the display is scaled globally through KDE's System Settings. In my case the display is set to 125%.

    Kubuntu does not use a Wayland session by default on 21.04, i have switched to that session on login to test it. Kubuntu is supposed to use Wayland as default in Kubuntu 21.10 and later. On the other hand Wayland is used by default on default Ubuntu (with Gnome) 21.04.

    At the moment, when Wayland is used, Firefox uses its own native Wayland implementation by default, while Chrome does not use a native Wayland implementation by default yet - it uses XWayland.

    So, the issue appears on both Chrome and Firefox when display scaling is used on Wayland and the option "Autosize popup windows" is enabled.

    You can enable native Wayland implementation in Chrome to test it with the flags "-enable-features=UseOzonePlatform -ozone-platform=wayland" when you start it.

  • Thanks for the info, what happens when you don't use the autosize option, do you have a screenshot?

  • When i don't use the autosize option it works correctly.

  • ok great, I must ask then why are you insisting on using the autosize option?

  • Well that's a good question. Actually i do not know whether i insist or i do not insist. I just keep it checked because it sounds like it's smarter than it is without using it. So i decided to file this bug. :)

  • lol so I decided to make this optional to fix the bug :)

  • Sure, it kinda works with and without this little "feature".

This website uses cookies to ensure you get the best experience on our website. More info
Got it!