Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Tooltip stopped showing

Good day,


The tooltip stopped showing. The icon blinks when I hover over it but nothing happens. I tried re-installing the extension and restarting the browser but nothing helped.


Would be happy to provide any info required for debugging.


Cheers!

Comments

  • Can you send me a screenshot.

  • @Jason Here is a video although the mouse cursor isn't showing but I hope you get the idea.

    https://www.loom.com/share/35c556b880634c3ca6508203516b2c39

  • @Jason Just gave you access to the video. Sorry about that.

  • ok thanks, which extension version are you on?

    You can visit the extension page to see that: chrome://extensions/

  • and did you change any options recently?

    also can you ensure this option is checked.



  • I played around with the options when I first installed the extension a few hours back.

    This option is checked yes.

  • I don't have any experience with chrome extensions. Is there any way to maybe see the logs of what the extension is doing when the hover action happens?

  • I got the "developer mode" on and I can see the following warning in the dev tools:


    ​"Response probaby text only: SyntaxError: Unexpected token | in JSON at position 0

    fetchJSON @ common.js:2301"

  • The error is gone after a refresh and the issue persists so it wasn't probably related.

  • So I did a reset to the default settings (from the admin menu), logged in again and the tooltip started showing up.

    Then I restored my settings from the admin menu, and the issue is reproducible again.

    Let me see if I can isolate the exact setting that is causing this weird issue.


    Also, sorry for the stream of messages.

  • Awesome, that's good news as i'm hopeful you'll likely narrow it down to specific options or even maybe a specific event that mjght be breaking the tooltip display.

  • edited May 9

    FOUND IT.

    If I set "Number of days to look ahead" (in the General tab) to anything bigger than 2; the issue is reproducible.

  • Ok excellent, ill investigate this in the morning, was 2 days the default? sorry so many options I forget 😀

    I wonder if a particular event is breaking the tooltip logic

  • It was 2 days by default. If your assumption is correct then it should break tomorrow when the new day rolls in.

    Will keep you posted if so.

  • So I tried changing the it to 7 days and it worked immediately for me.

    Do you have many events coming up in your calendar?

    Which calendar view are you using?

    After a reset is the max days ahead the only option you changed?

  • "Do you have many events coming up in your calendar?"

    Yes, I use my calendar as my to-do list so it is packed with at least 25 events per day.


    "Which calendar view are you using?"

    Weekly


    "After a reset is the max days ahead the only option you changed?"

    Yes

  • Hmm so my other hint is maybe the large number of events you have in your calendar might be interfering, also considering when you increase the max days ahead with that many events it would be a very large and long tooltip, perhaps that's the blinking you see and it failing to show, could be an OS/Chrome issue.

  • Yes, it could definitely be an OS/Chrome issue. I would say you shouldn't waste more time on it (unless you want to) because it's such a corner case. I mean who has this amount of events in their calendar anyway.

  • Well I don't like bugs as they could lead to bigger issues so that's why I like squashing them. You could do other tests by increasing that max ahead days again but then slowly hide some calendars that might reduce the number of events in the tooltip: https://jasonsavard.com/wiki/Visible_calendars_in_popup_window

  • Yup, tested that. It is definitely an issue with the length of the tooltip.

  • @Mohamed Hazem ok in the next update i'll put a limit to the max characters allowed in the tooltip, do you have any idea what it is approximately?

  • I think it highly depends on the screen size/resolution. I was able to view a tooltip that spans the whole vertical length of my screen but once it goes beyond that, the tooltip stops working as we've seen before.

  • Hmm i'm suspecting this might be a Linux specific issue.

  • How do you know I'm running Linux?

  • user-agent when you post on this forum.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!