Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Recent Tabs: Not working

Hi jason,

Has there been any updte to Chrome that disables the recent tabs function.

Can't get it to work.


Have tried Usage #2.

Want to use Usage #1, but I can't find the Keyboard shortcuts button that is mentioned.

--

John

Comments

  • So when you go to this page:

    chrome://extensions/shortcuts


    You should see this:



  • Look at that. That fixed it!

    The Usage #2 did not work, but assigning in Usage #1 it is working.


    Thanks for the help!

    Did not think about checking the top left menu 🙈

  • Hi Jason, I have been using Ctrl+Space for more than a year. After a recent update (either Win or Chrome - since April 17) the combination stopped working. I am used to using it automatically. Is there a workaround/fix that can be applied? Thanks!

    Best, Den.

  • @Denys Sokolov I use the software AutoHotKey to capture any key combination and convert it to another one that extension can recognize ie. Ctrl+Space .. Ctrl+Shift+1 and then set Ctrl+Shift+1 in the extension shortcut keys.

  • Hi Jason,


    Since the last update I'm having an issue with recent tabs not recognising some tabs. With certain tabs it works fine, but with other pages it will swap back 2 tabs, and then just between that tab and the next one.


    Example:

    I open tab 1

    Then I open tab 2

    Then I open tab 3. I press 'alt + a' (my designated shortcut) hoping it will swap back to tab 2, but it goes back to tab 1, and then continuues to swap only between tab 1 and tab 2, never returning to tab 3.


    I'm using Usage #1 and only want to swap between my previous 2 tabs.


    I appreciate any help.

  • edited April 20

    I too used this to flip between the last two tabs. About 3 or 4 days ago. It stopped working. I used alt-q ... I tried shift-alt-q and that doesn't work either? Any thoughts on why this stopped working?


    I tried the 2nd option and it wouldn't let me type alt-q, so I tried alt-j and that didn't work. I then tried alt-j in the 2nd option and it doesn't work there either. It appears Chrome has done something to mess with this extension. :-(

  • @Vaughn Seward @Chris Thompson i recommend reinstalling the extension since sometimes updates causes issues.

  • That seems to have fixed it. Thanks a lot Jason!

  • edited April 22

    Hi @Jason, I have also starting having problems since 20th April on MacOS. The funny thing is that my usage is so instinctive now it's got me left doubting myself!


    My usage was to use ctrl+tab to toggle between the two most recent tabs. Now the ctrl+tab behaviour seems to have defaulted to the Chrome default which is just to cycle through all open tabs. Trying to set the keyboard shortcut for the extension to ctrl+tab isn't possible as it just switches tab! If I choose something like ctrl+q as the shortcut it works fine. I have tried reinstalling to no avail. My brain is so hardwired to ctrl+tab, I can't switch to ctrl+q!


    Please help!

  • edited April 22

    Actually it could have been option (alt) + tab I was using. However, same problem, I can't capture that as a shortcut key.

  • Hi @Jason , I saw that but I believe that only applies to Windows and I'm on MacOS. My point is more that something has changed with the latest Chrome update, but I'm not entirely sure what it is.

  • @Kevin Herring

    I also pushed an update so if there any issues just reinstall the extension.

    But it's also possible Chrome reserved more shortcut keys for their internal use only.

  • Thanks @Jason, I suspect you are right that option-tab has become reserved now. Argh!

  • edited April 27

    I use Recent Tabs regularly on Windows 10 and Chrome OS. I sign into Chrome on both to sync everything but open tabs. Recently, the Chrome OS shortcut key stops working and the short-lived workaround is to remove and reinstall the extension, which is annoying. I reinstalled yesterday and this morning it is not working again. This problem started about a week ago. This is not happening with Windows 10.

    Windows 10 Chrome Version 90.0.4430.93 (Official Build) (64-bit)

    Chrome OS Version 90.0.4430.86 (Official Build) (64-bit)

    On both systems I remapped the modifier key left of A to be ctrl and configured shortcut ctrl+, to toggle tabs.

    What should I do to get back to normal?

  • @Bruce Wong Most likely it's related to specific keys and the OS, have you tried other keys, you may want to investigate the AutoHokey mentioned here https://jasonsavard.com/wiki/Recent_Tabs

  • @Jason https://www.autohotkey.com is only for Windows. My problem is with Chrome OS. Windows works fine for me. On my Chrome OS system I'm just now using alt+, since I have not remapped the alt key I'll see if the problem goes away. I don't know what makes it stop working after I reinstall and configure the hotkey.

  • @Jason Using alt+, also eventually stopped working. Interestingly, I went here using my chromebook and saw this warning:

    Detected Chrome 'alternative based browser' and not the stable channel of Chrome. I cannot support bugs on non-stable versions. DETAILS & DISMISS

    Any idea why this is happening with Chrome OS Version 90.0.4430.86 (Official Build) (64-bit) ?

  • @Bruce Wong You can ignore the detection warning, seems my version detection is slightly off for Chrome OS https://jasonsavard.com/en-CA/Chrome-Channel-Releases

    Maybe try more complex 3 key shortcuts to see if they work like Ctrl+Shift+(other key)

  • edited April 28

    @Jason This morning I made the shortcut Alt + Shift + T and it worked until it stopped working late in the afternoon. Nothing else changed in between; there were no restarts -- just normal usage.

  • @Bruce Wong Does simply restarting the browser or reloading the extension resolve it temporarily? (i'm not referring to reinstalling)

  • @Jason chrome://restart does not fix it. Disabling and then enabling the extension also does not work. I just did both. Reinstalling is the only workaround so far.

  • @Bruce Wong Can you try disabling the Chrome extension sync, then reinstall the extension on the machine with the problem, perhaps it's the sync that is breaking things.

  • @Jason I did that later on April 27, so the recent failures happened with extension sync disabled.


  • @Jason I saw that there is another condition for my problem on my Chromebook. When it happens lately, it has involved two pinned tabs. Selecting each tab and then trying to switch does not work, but if I unpin both then switching works. After I re-pin them switching continues to work. I still don't know what causes it to eventually fail and why I don't see it with Windows Chrome, but now I have an easier workaround.

  • A possible reason why this doesn't happen with my Windows Chrome is it has 4 pinned tabs instead of the 2 pinned tabs on my Chromebook. There are many instances when my chrome browser has only pinned tabs open.

  • @Bruce Wong I did just test with my pinned tabs on Windows and it toggled between them.

  • @Jason after it is working, it continues to work for about a day before the problem shows up on my Chromebook. I have never seen it with my Windows Chrome, where I always have 4 pinned tabs. I'm not going to reduce it to 2 pinned tabs to gather more data since I'm satisfied with the current workaround on my Chromebook. Thanks.

  • Just wanted to add my experience to this thread — the shortcut stopped working today after a Chrome (Mac) reboot/update. Before I rebooted the browser, I experienced the "jumping to the wrong tab" issue that others have mentioned, later followed by no reaction to the shortcut at all.


    After the browser reboot, the extension was disabled and Google noted that some new permissions were needed, which I had to approve. Upon approval and re-activation of the extension, it still didn't work. Shortcut was still set to the one I usually use (alt+q), but there was no reaction at all.


    Uninstalling and re-installing the extension seems to have worked, and everything is back to normal for now.


    It's weird how crippled I feel without this extension, so odd that this isn't default functionality for Chrome. Thanks for all your hard work, @Jason!

This website uses cookies to ensure you get the best experience on our website. More info
Got it!