Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Slow Popup Window

1235

Comments

  • edited March 1

    Slow here too now on Mac 11.2.1 with latest chrome.


    ...Jason hidden...


    Reset to default seems to have helped a bit, for now.

  • @william.rolison can you reinstall the extension to force v22.5.5 which may solve the issue which sets the indexeddb to relaxed by default.

  • Done, thanks

  • @Jason 9 days have passed since I reinstalled this extension and set IndexedDB relaxed.

    For now it works pretty fast. Can't see any significant speed degradation.

  • @comrade.me Yay, thanks for getting back to me, it looks like we may have solved the issue, thanks everyone for your feedback.

  • Hi Jason, unfortunately as of this week, the extension has slowed again and is now taking more than 10 seconds to load. This is with the IndexedDB relaxed set as active. Was working fine last week!

  • @nwb403 so after 1 week almost no slowness, but after 2 weeks it went to very slow? And you enabled that relaxed option from the start?

    I am still wondering if 1 of your other extensions are interfering, i know you tried some disabling tests, but note that once the slowness occurs it seems only a reinstall of the extension can reset it.

  • Jason, yes, that's right. Be good to see if anyone else has the same repeat issue. I'll reinstall again and see if I can live without any of the extensions!

  • edited March 8

    Update: I had about a month or two of normal operations - the speed has degraded over a few days.


    To give an idea of the speed I attach an animated GIF (it is not frozen :))

    The serialization results are:

    [hidden by jason]

    size: 150,869

  • @Wojtek Swiatek Can you tell me which extension version you were running? The latest one v22.5.5 has a new "relaxed" feature enable which I'm trying to determine if it resolves the issue. Obviously this is a pretty difficult bug if it only occurs after a month or two :(

  • It is 22.5.5. I just tried to look for the "relaxed" option but could not find it.


    Yes, I know that with this kind of bug it is very hard to pinpoint the issue. The only thing I noticed, if this can help, is that the deterioration was quick (~days).

  • edited March 8

    @Wojtek Swiatek Interesting so my only other lead is possible disruption by other extensions that users have installed. Would you be able to uninstall some of them for a little while to determine if that's the case. fyi the relaxed option is set on by default in v25.5.5

  • edited March 8

    @Jason yes, I can sure do that.


    FWIW I just tried Incognito mode with only your extension available and the issue is still there.

    Also: I have about one screen of email only (the rest is archived)

  • @Wojtek Swiatek I should also add that after uninstalling other extensions, you'll have to reinstall my extension because that's the only way to reset the slowness.

  • @Jason


    OK.


    I just tried to uninstall your extension, close the browser and reinstall it and it is fast again. I guess that this is a known workaround.

  • This slowness issue makes the extension pointless to use. It seems the more unread mails you have, the longer it takes to load up the preview. Reinstalling or resetting to default fixes the issue for a very short period of time.

    Could we just have a simple extension without all the fancy bits and pieces, just the preview of emails and archive, delete or open options only???

  • @GuillermoCordeiroGarcía The issue is related to a specific storage area so it could affect other extensions, regardless of their complexity. Do you have other extensions installed? I'm trying my best to determine the cause, how many days until you notice the issue?

  • Hi @Jason, I haven't really counted the days, the only thing I am certain is: the more unread emails the longer it takes to show preview and with few unread emails (say 5 or 6) it happens ramdomly and previews load up ok or not.

    As for other extensions, I have a few installed and have disabled as many as I could but the behaviour seems unchanged.

  • @GuillermoCordeiroGarcía So coincidentally most users with the issue do seem to have a fair number of other extensions installed and I'm wondering if it's the culprit. Can you tell me if slowness is resolved "temporarily" with the Gmail extension option .. Admin .. Reset settings to default ?

  • Using that option to reset settings does fix it temporarily @Jason

  • @RickVanHattem Did you permanently resolve the issue? ... by manually deleting all google cache files through the filesystem instead of through chrome

  • @GuillermoCordeiroGarcía So could I ask that you disable all other extensions for the test period of a few days to see if the issue returns?

  • @Jason I am afraid I can not fully disable them all, I could try and lower them to a minimum at most.

  • edited March 9

    @GuillermoCordeiroGarcía So I'm following up on 2 users who might have permanently resolved the issue by manually deleting their Chrome cache files, I invite you to try that, you'll have to close Chrome first (this is the path to your windows default Chrome profile) %LOCALAPPDATA%\Google\Chrome\User Data\Default\Cache\

  • OK @Jason, I have now deleted all the chrome cache files. I will update within a week or so and tell you how it goes. Thanks.

  • @Jason yes, it seems to have fixed it permanently

  • edited March 11

    I have always had to reinstall the app after a couple of months hopefully %LOCALAPPDATA%\Google\Chrome\User Data\Default\Cache\

    will help.

  • I've enabled the "IndexedDB" option on February 22. It's March 11 and the extension is blazing fast as it should.

    I really think this solves the issue... I am SO happy to be able to use it again!!!!

  • @Massimiliano Nyllover That's good to know because I've turned that on by default with the latest extension version, thanks for writing back.

  • @Jason A week later everything seems to be working well, I will keep updating!

This website uses cookies to ensure you get the best experience on our website. More info
Got it!