Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Slow Popup Window

There is a small popup window which appears when the Google Checker plus icon is clicked that shows a preview of all unread messages in my Inbox. However, recently when I click this icon, it can take up to 10 seconds for the popup window to appear.


I am running the latest version of Chrome with MacOS X 10.14.6.

«13456

Comments

  • Try reinstalling the extension.

  • I have already tried this.

  • As well as restarting the browser

  • Are you using the default options after you reinstalled the extension?

    Do you have a lot of other extensions?

  • I have not changed the settings in any way since reinstalling.


    I have 9 other active extensions, and 6 inactive.

  • Do you have my other extensions, like calendar etc. how are they behaving?

  • No, I don't have any of your other extensions.

  • I'm going to monitor the situation, as of now I'm not getting any other reports from Mac users. Have you tried creating a test profile with no other extensions: https://jasonsavard.com/wiki/Chrome_issues

  • edited August 2020

    I'm having the same problem. All of a sudden, the extension has been running very slowly. When I click on an email in the pop-up window, it takes upto 30 seconds sometimes for the email to load. I have tried reinstalling the extension, logging out of all my accounts and restarting my browser. I have not changed any of the extension's settings when this problem cropped up. Any ideas? Thanks!

  • When you reinstalled the extension did you use the default settings (not restored any)

    Have you changed any Chrome flags?

  • I am also having the same issue: Popup window is very slow to load. I also see the same behavior when loading the options window. This is started about a month ago. I uninstalled/reinstalled the plug-in and performance returned to normal. Slowly over the last 2 weeks or so it has degraded. This morning I again uninstalled/reinstalled the plug-in and performance was back to expectations. I did not restore any setting during either install. I have since made changes to the setting for the notifications and other options but these are the setting that I have used since basically day one and match across multiple machines.


    It does appear to be specific to a given machine. I do not have the performance issue on a VM I have or my laptop. This may not be a great case since those are Apple devices while the performance issues I have are on a Windows machine.


    I have changed several Chrome Flags to enable/disable various features:

    -Extensions Toolbar Menu: Disabled

    -Tab Groups: Enabled

    -Hardware Media Key Handling: Disabled

  • @Mike Nowill Have you tried just restarting the browser instead of reinstalling the extension?

    Does the performance degrade suddenly or slowly over time?

  • @Jason Restarting the browser or rebooting the PC doesn't make a difference. I think its more of a sudden wall but it might be happening over time and I don't notice it until it hits a threshold.

  • edited August 2020

    @Mike Nowill It seems some users get file/db corruption issues overtime perhaps it's Chrome's writing to drive, have you tried clearing OS temporary files and free up space or disk defrag. Honestly it's very difficult to determine and considering you seem like a power user given the flag changes, there maybe other system/chrome changes that are likely the culprit.

  • @Jason Disk Defrag doesn't really matter on solid state drives but Windows is setup to optimize the drives weekly. I do not typical clear out the OS temporary files on any cadence.


    While certainly anything is possible when it comes to the various flags being changed it seems unlikely given the 3 flags that have been changed. I would also expect the issue to present itself across machines if those flags are also set there which doesn't appear to be the case.


    No worries...I thought I would chime in as it appears others are having a similar experience, although not necessarily being report widely and add some additional details that you had request from others but didn’t seem to get a response. Coming from a software developement background I can relate to how hard it can be to troubleshoot something when you don;t get enough detail or background.

  • edited September 2020

    I am experiencing the same slow pop-up. I thought it coincided with trying to get a dark background and adding a theme, but, I took the theme away and it persisted. There could be a conflict with another extension. Any suggestions would be great.


    Edit: I disabled all of the other extensions with no success. I ended up uninstalling and reinstalling and hitting the RESET on the themes and added options and that seemed to significantly improve the response. So, I think there is a theme or skin addition issue.

  • @Jason Like @Mike Nowill I am getting the slow pop-up as well. As instructed, I re-installed the extension last month as you can see on my above post. Like Mike, it is slowly over time deteriorated back to an excruciatingly slow pop-up. Do you have any Chrome flags that I should check? Like Mike, I do NOT have the same issue on my laptop and they both sync Google and extensions. I am at a loss as to what could be causing it. I, too, have SSD drives.

  • Hi! I am having the same issue since about a month ago, or so. Veeeery slow pop up.... I'm on a Windows 10 laptop with SSD, Core i7 CPU fairly buffed up other specs. I've tried reinstalling the extension without much improvement. I can't modify my browser, because it is managed by the IT department of the company I work for. Didn't have this issue earlier.

  • @Jason


    I inspected the pop and these are the results. Seems like an incredible delay around getBGObjects. Does this help?


    initMisc

    common.js:4889 storage.init()

    popup.js:39 zoomfactor: 29.9609375 ms

    extensionCommon.js:28 vulcanized-polymer.js: 521.31103515625 ms

    extensionCommon.js:28 vulcanized-polymer2.js: 226.072998046875 ms

    popup.js:487 getBGObjects: 4584.630126953125 ms

    popup.js:1242 setting height

    popup.js:4060 renderMails: 0.006103515625 ms

    popup.js:4060 renderMails: 0.01416015625 ms

    popup.js:4060 renderMails: 0.005126953125 ms

    popup.js:4060 renderMails: 0.00390625 ms

    popup.js:4060 renderMails: 0.004638671875 ms

    2popup.js:4060 renderMails: 0.005126953125 ms

    popup.js:4060 renderMails: 0.0048828125 ms

    popup.js:5427 init: 8465.8828125 ms

  • @keith.bell So this is slow time for the getbgobject call, it seems to be storage related and this could be impacted by other extensions filling up storage as well and slowing it down, I know you disabled them, but that wouldn't flush their storage. What are you other extensions? Are any possibly consuming a lot of space/configurations?

  • @Jason ewwwww, I have tons of extensions:


    CheckerPlus for Calendar

    Adblock

    AAdvantage Shopping

    Adobe Acrobat

    Rakuten

    Adblocker for Yahoo Mail

    X-Notifier

    Hover

    Mailto: for Gmail

    Downloader for Instagram

    Evernote

    Free Music Downloader

    SABconnect++


    I am in agreement that it must be a cache or space issue. I tried again. I deleted all cache, cookies, history. When I delete and reinstall Checker Plus for Gmail extension, it works great. For some reason, it simply starts to slow down after about a week of usage.


    Keith

  • @keith.bell So my next test for you would be to try disabling half of those extensions for a week (those most likely to interfere you think) and see if that resolves the issue. I realize this a long test because as you state it seems to take a week before the issue arises.

  • @Jason , I'm running Edge Chromium Version 86.0.622.63 (Official build) (64-bit) on Windows 10 in an office environment and connecting via a corporate VPN. I am experiencing the same issues. I did not experience these issues until recently as is the case with others posting here.

  • @AlanSwitzer Can you list other extensions you have installed?

  • edited November 2020

    @Jason


    Note - Edge Chromium Stable just updated to Version 86.0.622.68 (Official build) (64-bit) and the Checker Plus extension pop-up is now opening at normal speed again. I will report if I experience slow-downs again.


    Google Translate : version 2_0_9

    1Password X – Password Manager : version 1_22_1

    uBlock Origin : version 1_30_6

    Checker Plus for Gmail™ : version 22_3_1

    Outlook Edge : version 2020_8_25_47310

    GoFullPage - Full Page Screen Capture : version 7_1

    OneNote Web Clipper : version 3_8_2

    Checker Plus for Google Calendar™ : version 27_3

    lsiwebhook : version 2_0_1 (corporate computer instalation.

    Notion Web Clipper : version 0_2_3

    Office : version 2_2_4

  • edited November 2020

    I also started experiencing this suddenly about a week or so ago. It takes about 15 seconds to load. Before the recent update, or loaded in one second. I have Windows 10 and Chrome Version 87.0.4280.66 (Official Build) (64-bit) and Windows 10 Home with the latest updates. Here is a list of my extensions:

    ahfgeienlihckogmohjhadlkjgocpleb : Web Store : version 0_2

    apdfllckaahabafndbhieahigkjlhalf : Google Drive : version 14_5

    blpcfgokakmgnkcojhhkbfbldkacnbeo : YouTube : version 4_2_8

    bmnlcjabgnpnenekpadlanbbkooimhnj : Honey : version 12_8_2

    cfhdojbkjhnklbpkdaibdccddilifddb : Adblock Plus - free ad blocker : version 3_10

    coobgpohoikkiipiblmjeljniedjpjpf : Google Search : version 0_0_0_60

    fnpbeacklnhmkkilekogeiekaglbmmka : Norton Safe Web : version 3_13_1_3

    gfdkimpbcpahaombhbimeihdjnejgicl : Feedback : version 1_0

    kmendfapggjehodndflmmgagdbamhnfd : CryptoTokenExtension : version 0_9_74

    mfehgcgbbipciphmccgaenjidiccnmng : Cloud Print : version 0_1

    mgijmajocgfcbeboacabfgobmjgjcoja : Google Dictionary (by Google) : version 4_1_5

    mhjfbmdgcfjbbpaeojofohoefgiehjai : Chrome PDF Viewer : version 1

    neajdppkdcdipfabeoofebfddakdcjhd : Google Network Speech : version 1_0

    nkeimhogjdpnpccoofpliimaahmaaome : Google Hangouts : version 1_3_15

    nmkinhboiljjkhaknpaeaicmdjhagpep : F.B.(FluffBusting)Purity : version 31_2_1_0

    nmmhkkegccagdldgiimedpiccmgmieda : Chrome Web Store Payments : version 1_0_0_5

    oeopbcgkkoapgobdbedcemjljbihmemj : Checker Plus for Gmail™ : version 22_4

    pidcjgldchekcoolelhbjfbnccjkckfj : BackStop : version 2_0_1

    pjkljhegncpnkpknbcohdijeoejaedia : Gmail : version 8_3

    pkedcjkdefgpdelpbcmbmeomcjbeemfm : Chrome Media Router : version 8720_1005_0_2

  • @PaulH So it seems users experiencing the slow down tend to also have several extensions installed, this is pointing towards a storage resource bottleneck, I would try disabling or removing some extensions and see which might be contributing to the issue.

  • Thank you Jason, but:


    1. I show seven extensions actually enabled when I go into my Extensions. That's not a lot for a system that has 64 GB of RAM, Intel Core i7 6800K CPU, Samsung SSD 850 EVO 2TB (SSD)for the main/system drive with 1.26 TB free, and is currently only running Chrome, Ditto and Malwarebytes. But I did disable all of them except Checker Plus. It didn't make any difference I could tell.
    2. Neither I nor any of the other users suddenly installed a bunch of extensions. The slowdown happened to us suddenly and recently, and nothing else in the browser or our systems is slow, so why is Checker Plus for Gmail suddenly unable to play with other extensions? And if I recall correctly, this started about a week or two ago immediately after a notification that my Checker Plus for Gmail had been updated. So it sort of looks like maybe there's something in the update causing this?


  • @PaulH I haven't made any significate changes to the extensions, especially changes that would only cause a gradual slowdown. This is more indicative of memory or storage and the best lead I have right now is from Keith's logs who showed the bottleneck with the storage access framework. Note that disabling other extensions doesn't wipe their storage, so it won't resolve the issue. I still need help identifying the source, so removing other extensions or possibly avoiding customizing the Gmail extension options or resetting Chrome flags could help me.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!