Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

OAuth2 request failed

I get an OAuth2 request failed error (-2) whenever the browser starts. But after that the extension just works fine. So it is basically an annoyance. I am on MS Edge.

Comments

  • Can you send me the error logs https://jasonsavard.com/wiki/Error_logs

    What other extensions have you installed?

    This might be related to a delayed internet connection on startup.

  • Other extensions:

    • Checker plus for gmail
    • custom new tab
    • google translate
    • nano defender
    • uBlock origin
    • OneNote web clipper
    • Reddit enhancement suite
    • Share tools
    • Vimium

    It happens every time I startup Edge when the internet connection is already established, not just after logging into windows.

  • Hmm so the full error does mention "connection fail": OAuth2 request failed: Connection failed (-2)


    Can you try disabling nano defender and ublock and do the restart browser test again.

  • Disabled all extensions, error remains. I also went through the options and noticed it also happens when I refresh notifications.

  • How do you refresh notifications?

    Have you tried reinstalling the extension?

  • On the options tab "Notifications" in the section "Notifications for calendars" it has a refresh button. Hitting that, or adding a calendar triggers the error.

    I'll reinstall now and let you know.

  • I should have tried that first. Seems to have resolved after reinstalling. Sorry for wasting your time.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!