Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

TypeError: Cannot read property 'chooseDesktopMedia' of undefined

Jason,


Hi again. I'm the guy that made the rectangle/square obfuscation change request that you implemented. Thanks again. I've got an issue. I thought it was due to me being in Google Docs or something, but it seems no matter what page I'm on I get the same error.


Whenever I try capture "Screen" I get: TypeError: Cannot read property 'chooseDesktopMedia' of undefined

Comments

  • Are you using the popup window from the button?

  • I used a different app to capture that - if you're wondering.

  • Thanks for the screenshot, so that's a right click, can you try a left click on that button and then the screen grab menu item.

  • Noted. Okm, know then that this feature can't be enabled with people that have that issue (see screenshot)


  • ok thanks, i'll keep my eye out for more reports of this one, did the issue get resolved after using the left click?

  • Yep that solved the issue. Thanks!

  • edited June 2020

    I was running into this error as well, but only on record screen. Reinstalling the extension and restarting Chrome did the trick. The UI looks super Material now, so obviously my extension wasn't updating for whatever reason.


    I'm good!

  • edited June 2020

    -

  • Hi Jason! I get the same error Cannot read properties of undefined (reading 'chooseDesktopMedia') when trying to record screen (video). Static capture works just fine.

    Manjaro Linux (latest stabe), Chrome Version 112.0.5615.165 (Official Build) unknown (64-bit)

    plugin 13.0.1



  • @MaxNizamov Have you tried resinstalling the extension.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!