Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Unable to record screen on Mac OS

Hi Jason,


Whenever I start a recording, the bar at the bottom to stop the screen sharing will disappear after a few seconds, leaving me no option to stop the recording.


What can I do?


Thanks!

Comments

  • Try reinstalling the extension.

  • I did that already with no luck.

  • I tried Google Meet screensharing and there the bar with the blue stop sharing button does not disappear.

  • Let me know which extension version you are running and i'll investigate, might be a Mac related issue.

  • Thank you! I am using the latest one 10.0.2


    Let me know how else I can help to help you fix it!

  • I just tested it on a Mac without a problem, can you give me more details,

    how many seconds until the issue happens?

    are you recording video and audio?

    do you move the mouse or just idling when recording?

  • ok great videos, so i noticed it took ~15 seconds,

    i also noticed you started the recording by right clicking the icon,

    does the issue also happen when using the extension popup window and then record video menu?

  • Strangely, I click on the icon with normal click and nothing happens!


    Probably because the video is somehow still running in the background and hasn't finished?

  • Might have to disable/renable extension or have you tried restarting the browser.

    then try the menu again.

  • Disabled, renenabled.


    Restarted Chrome.


    The issue keeps happening. :(

  • and you tested with the normal left click and via the popup menu?

    ... if so, i'll do more tests with the mac and see what I can find.

  • Yes, I tested both!

  • I tested it again, and it still works, I'm also not getting any other reports about this. I'm wondering if it's a storage issue.

    Can you let me know if there any error logs after the recording stops ...

    https://jasonsavard.com/wiki/Error_logs

  • OK, will try to give you the error logs. Thanks for all your efforts!

  • Guess what, it's working if I keep the devtools window open!

  • good information, that proves the issue is related to the automatic unloading of the extension after ~5 seconds, however there is code to keep it alive and i'm not sure why it's not working on your instance.

  • Yeah, strange...I tried several other screencast tools like Screencastify and I don't have any issues with them.

  • So the unload of the extension is an opt-in by the developer - which I have enable on all my extensions to save resources - it's actually really cool, because when they are not used for ~5 seconds they are complete unloaded from memory. Note that will be the enforced for all extensions in the near future.

  • Ok i discovered the issue, it's related to a recent update, I have found a fix and will be pushing in the next days in v10.0.3

  • Oh, this is great. Thanks so much Jason!

  • Can confirm the new version is working. Thanks Jason. :)

This website uses cookies to ensure you get the best experience on our website. More info
Got it!