Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Inbox Popup Empty on Chrome 80

After updating to Google Chrome 80, using Inbox (Gmail for Mobile) Popup on Checker Plus for Gmail just yields an empty popup window. I checked the console and found out that the problem was caused by Chrome 80's new cookie policy that changed the default attribute from SameSite=None to SameSite=Lax, likely causing the popup to break because it can no longer read cookies from Gmail.


I managed to fix this by going to chrome://flags and setting #same-site-by-default-cookies to Enabled which sets the default attribute back to SameSite=None, but this might be something that you might want to keep an eye on and fix permanently, because Google might take that flag away without warning anytime soon and break this feature without any possible workarounds.



Comments

  • edited about three weeks ago

    oh wow, great discovery, and you confirm that if you renable this flag that the issue returns?

  • edited about three weeks ago

    Ok I confirm the issue.

    If anyone has some workaround code to help me, let me know. Perhaps by using the webrequest https://developer.chrome.com/extensions/webRequest the modify these SameSite cookie attributes, or else I maybe to have remove the inbox view and stick with only unread emails.

  • edited about three weeks ago

    @Jason Sorry for the late reply. Yeah, setting the flag to Enabled (made a mistake on the original post, 'Disabled' will temporarily fix the issue, not 'Enabled') will make the Inbox popup empty again but I guess you found out about it already. Hoping there's a way to keep the Inbox popup because I enjoy being able to see both read and unread emails without having to open the full Gmail website. Thanks, Jason!

  • Not working here, on Vivaldi. Tried both Enabled and Disabled.


    https://i.postimg.cc/Kzc6pLsR/2020-03-24-19-54-21-flags-6d061e15e0ab.png


    Vivaldi 2.11.1811.49 (Stable channel) (64-bit)

    Revision cac8cb477e6de02013662fb5f48ac1a82bca666b

    OS Linux

    JavaScript V8 8.0.426.27

    Flash 32.0.0.344 /usr/lib/adobe-flashplugin/libpepflashplayer.so

    User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.158 Safari/537.36

  • @PaulB It should be resolved in the latest extension v22.0.2.7 try reinstalling to force the update.

  • Thanks, @Jason, that sure did fix it immediately. I don't understand it, though, because that version was already showing in vivaldi:


This website uses cookies to ensure you get the best experience on our website. More info
Got it!