Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Uncaught Error: trans abort: QuotaExceededError (js/common.js 4541)

Since today I am not able to add an account. Tried to reinstall - all old accounts disappeared, but still not able to add any account apart main google account, which is auto-added.

Comments

  • Can you send me your error logs https://jasonsavard.com/wiki/Error_logs

    As well are you using auto-detect or manual add? https://jasonsavard.com/wiki/Account_sign_in_methods

  • edited March 12

    By now I using auto-detect, as I cannot do a manual add, there is no button at all. When I choose " Add Accounts and stay signed in" it shows me error mentioned above and nothing changes. That's what I want to change and use manual add. Also even if I disable the account same error shows...


    There is actually not much more than what I wrote in the topic title. Here:


    Uncaught Error: trans abort: QuotaExceededError

      at IDBTransaction.trans.onabort (common.js:4541)

    extensionCommon.js:197 Uncaught Error: trans abort: QuotaExceededError (js/common.js 4541)

    showError @ extensionCommon.js:197

    options.js:120 onMessage Object

    options.js:120 onMessage Object

    options.js:120 onMessage Object

    options.js:120 onMessage {command: "indexedDBSettingSaved", key: "ignoredAccounts"}

    options.js:120 onMessage {command: "indexedDBSettingSaved", key: "unauthorizedAccounts"}

    options.js:120 onMessage {command: "indexedDBSettingSaved", key: "accounts"}

    options.js:120 onMessage {command: "indexedDBSettingSaved", key: "unauthorizedAccounts"}

    options.js:120 onMessage {command: "indexedDBSettingSaved", key: "accounts"}

    options.js:120 onMessage {command: "indexedDBSettingSaved", key: "unauthorizedAccounts"}

    options.js:120 onMessage {command: "indexedDBSettingSaved", key: "accounts"}

  • When you reinstall the extension are there any errors produced? does it detect your accounts correctly?


    and do you see any errors in the interface or only in the extension logs

  • edited March 12

    No, it did not detected any accounts. It did not told any errors, but when I try to get add one more account it shows error above. Error shows in interface popup in the bottom left with link to this forum. Also all new mails I see popup about them, but they do not show in interface and cannot reply (the one like was with notification for your reply).

  • Can you send me screenshots of the issues you see so I can better understand the context. One last resort we can try is this after https://jasonsavard.com/wiki/Corrupt_browser_profile

  • No, corrupt profile did not helped. I added new user, with your as only extension, and still same error when I try to add an account.


    https://imgur.com/zFUidqv.png

  • ok thanks, so the error is indicating there is too much storage being used, i'm not sure why, when you reinstalled the extension did you make sure not to restore settings?

    can you try the instructions here with a test profile: https://jasonsavard.com/wiki/Corrupt_browser_profile

  • But I already did that, no? See my last screenshot.

  • yeah sorry our last messages were mixed.

    i'm wondering if this a linux specific issue with the recent update.


    Before you sent me options logs can you send me the background specific logs...

    1. Click the Chrome menu icon > More tools > Extensions
    2. Select Developer mode at the top right
    3. Find the extension and click the background link
    4. Select the Console tab


  • edited March 12

    They were same. Now I cannot reproduce the error in frontend because all accounts were deleted when I reinstalled the extension apart auto-account (but as you can see even auto-account do not work properly, as it does not show mails in inbox). And if I try to add there is that error in options. But believe me, it was same error.


    Is there a way to clear that storage you are speaking about?

  • So, I seems found the cause. There was exactly 1 GB remained in a drive with Google Chrome and it seems it decided that's too few to render extensions (that's really strange, as all pages and stuff open just fine). After I cleared space - my old accounts appeared and messages started working and no more error in Options.


    Seems you can close this, thanks for your time.

  • wow great research, this is very useful and might help others, can I ask which exact steps you took to clear the space?

  • Just found biggest file on disk (was some installation) and deleted :) I think it does not matter how, you just need more than 1 GB free on mount point (not sure how you call it in windows or mac os - drive? partition? the ones with C: D: etc.)

This website uses cookies to ensure you get the best experience on our website. More info
Got it!