Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Cannot read property '0' of undefined

I have got this error "Cannot read property '0' of undefined" and plugin can't see any of my new letters

Comments

  • I have this same error now. Getting no readout on the extension listing the number of emails. Extension is not working it seems. Started on 3/4.

  • @Don Signorino Have you tried restarting the browser?

    if that fails try reinstalling the extension. and let me know which works

  • @Jason Restarting the browser didn't work.


    However, reinstalling the extension did work. Not sure what this was, but it appears fixed now. Thanks.

  • Restarting the browser didn't work. Reinstalling the plugin didn't work too

  • I had similar errors after noticing that incoming emails weren't being displayed in the extension and tried logging out of my accounts and back in again which gave the property undefined error.


    Removing the extension and adding it back again does fix it temporarily but once I restart my machine I have to go do that again before unread emails are displayed. Usually clicking the resync accounts button fixes this type of error for me but at the moment gives the following error message:


    "Try signing out and into your Gmail accounts and then do this sync again. TypeError: account.syncSignInId is not a function"


    Signing out and back in to accounts doesn't get rid of that error.

  • @Matt Norman Thanks everyone for the details, can you send me the error logs https://jasonsavard.com/wiki/Error_logs

  • @Jason how can i send you the log?

  • You can private message me via this forum or use my email at top of website .. about .. contact

  • OK sent you a screenshot via pm with an error I get when the extension starts and the cannot read property '0' of undefined error.


    For some reason the other error I mentioned previously which occurs on the resync button doesn't get logged to the console any more, I definitely saw it in the console previously though.

  • @Matt Norman @Don Signorino Ok I'm pushing a possible fix in v22.0.2.2 I will write back here when it's live in a few days when the chrome team approves it, thanks for all the details, they are helping me a lot.

  • @Matt Norman @Don Signorino ok v22.0.2.2 is live, but I think the issue is still there because I discovered a better solution that I will push again very soon, however, can you reinstall to force this version just to make sure the problem still exists and let me know. Note the issue seems to be related to the starting of Chrome or restarting of your computer - so you'll have to test that.

  • I have had similar issues. Just installed v22.0.2, Restarted Chrome (Linux). So far, so good. Keeping fingers crossed.

  • It does not work more than it works.

    It is a great shame as it is a great concept.

    It was not much, but I paid into it, so a bit disappointed it is so unreliable.

  • @Neil H I've pushed a fix for this issue, to be released soon, it's only affecting small portion of users, as a work around just disable and renable the extension, the issue seems to be related to the startup.

  • Thank you Jason. I look forward to the update.

    Thank you for an awesome extension too :-)

  • Hi @Jason - yes still getting the issue on startup with v22.0.2.2 - will let you know what happens with the next version.

  • @Jason v22.0.2.2 solved the problem for me.

    Just a reminder, https://microsoftedge.microsoft.com/addons/detail/dkjkomkbjefdadfgbgdfgnpbmhmppiaa still are 22.0.1 and has the problem.

  • @YFYang ok great info, becuse v22.0.2.2 contained a partial fix, and v22.0.2.3 should have the full fix.

    Thanks for the Edge version reminder, I've also pushed v22.0.2.3 there and waiting for approval process.

  • edited March 10

    @YFYang refer to comment below

  • @Don Signorino @Алексей Голубев @Matt Norman @Neil H ok v22.0.2.3 has been released for both Chrome and Edge, you can reinstall the extension to force the update and let me know if it's working.

  • Just updated to latest version.

    I will let you know if the problem persists.


    Thank you,

    Neil :-)

  • edited March 10

    Hi @Jason v22.0.2.3 has fixed the error on rebooting and the Cannot read property '0' of undefined error when adding accounts.


    I do still get the following when trying to resync accounts


    Try signing out and into your Gmail accounts and then do this sync again. TypeError: account.syncSignInId is not a function


    This doesn't give a console error in the background page so presumably it's within a try/catch somewhere. However it's not really interrupting the day to day running of the extension so not a massive deal.

  • @Matt Norman Ok great news about the booting issue. The other sync issue will be resolved in v22.0.2.4

    Thank you everyone for the help in solving this issue.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!