Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Getting dialog box when deleting message

I get the following dialog box when I delete a message from the pop-out, instead of it going to the next oldest message:


TypeError: Cannot read property 'account' of undefined at openOtherMail (chrome-extension://oeopbcgkkoapgobdbedcemjljbihmemj/js/popup.js:2494:37) at openNextMail (chrome-extension://oeopbcgkkoapgobdbedcemjljbihmemj/js/popup.js:2479:2) at autoAdvanceMail (chrome-extension://oeopbcgkkoapgobdbedcemjljbihmemj/js/popup.js:2517:3) SEND FEEDBACK


Comments

  • Does this happen everytime?

    Which detection method are you using? https://jasonsavard.com/wiki/Accountsignin_methods

    Can you send me a screenshots of the emails just before you get that error?

  • Doesn't happen every time.

    What do you mean by detection method?

    I'll screenshot the next email when it arrives.


    Thanks.

  • ok thank you and can you send me a screenshot of the unread emails in the popup window before you click to preview them?

    You said it doesn't happen all the time, do you see a pattern? is it always the last email? do you have multiple accounts?

  • It seems to only happen when I click on the message and then scroll within it. Then, when I click on "delete" (the garbage can), that's when the box pops up. When I then click the back arrow, the same message has been deleted.


  • ok great details, another question are you usually previewing the first email at the top or the last one when the issue occurs?

  • I preview from the top, then I either delete it or go to the next one via the arrow.

  • I'm having trouble replicating the issue, let me know how many unread emails you have left when you do get the error, i'm curious if it's when you're processing the last email in that window or if it's related to the 2nd account you have listed in the popup.

  • It's always random.

    Here's another dialog:

    "Uncaught TypeError: Cannot read property 'account' of undefined (js/popup.js 2494)"  When I click on the down arrow after the last arrow.


    I hardly get any emails in the 2nd account.

  • Have you tried reinstalling the extension?

  • I'm getting this after deleting / marking read more than 12 emails in menu bar hover.


    I have around 250 unread.


    I starts working again if I close hover and reopen it again


  • @David Kaspar That's a different error/issue, you can resolve that issue by using the manual add https://jasonsavard.com/wiki/Account_sign_in_methosign

  • Oh great! Thanks for a fantastic extension. Have been using it for years... Donated at least once 👍

  • Yes, that was the first thing I did (reinstall)

  • Can you tell me what do you have for this setting...



  • After reinstalling the extension are there any other settings you changed? As I can see now that you changed the Auto-advance from newer to older.

  • I'm going back and forth changing these settings. this the current general settings. I'm just waiting for more emails


  • ok good, so what you could help with me is determine which settings might be causing the issue. to be sure it's the settings you can reinstall and stick with the default settings then return them back one by one between tests to see what is the culprit.

    my assumptions is might be related to the previewing marks as read and the audo-advance

  • edited about three weeks ago

    @Jason Worked, thanks!

  • Hey Jason,

    Well...after going crazy for a few days, i think I finally solved it. I changed a few things back and forth. Then , yesterday, after I received a Windows update on my PC, I think that's what resolved it. Dont know for sure. It might also have been when I unchecked "Previewing marks as read".

    I'm going to re-check it to see if it still works. If it doesn't, I'll let you know.

    Here's a current screenshot:



This website uses cookies to ensure you get the best experience on our website. More info
Got it!