Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Notification indicator takes too long to update

Following up from


It has been like this for as long as I can remember so I know that restarting browser won't fix it. I mark as read both ways. Perhaps it is only happening when I use one of these two methods? I will watch it more closely now to see.


I'm using two computers, both with Chrome stable, and it is happening on both of them.

«1

Comments

  • ok let me know any details and specific click actions to reproduce it, so i can better investigate and replicate it on my end

  • Ok, I have a clearer understanding now.


    It's not that the unread indication (the icon being red and having a non-zero number badge) STAYS on after I use the 'mark all as read' command, rather the indicator turns off but then erroneously turns back on several seconds later. This happens consistently on my 2 laptops.


    I have attached the console log for the popup window that shows no unread emails (which is correct) though the icon is red and has a badge.



  • So the unread count is incorrect after marking an email as read?

    How many unread emails do you have?

    Which detection method are you using? https://jasonsavard.com/wiki/Account_sign_in_methods

  • I'm using "Add Accounts and stay signed in" so that I can use the "real time" polling so that it uses the push notifications instead of polling.


    The number of unread emails is usually between 1 and 4. For example, let's say it is 3, and I then click the mark-all-as-read action. The icon goes grey and the badge disappears, but then several seconds later the icon goes back to red with the '3' badge. If I click on the icon again, it correctly displays no messages (they were all marked as read).


    Eventually this mismatch resolves itself: the icon goes back to grey and the badge disappears.

  • ok thanks and can you let me know which labels you are monitoring the options > accounts/labels, this will help me replicate the scenario on my end.

    As well which button are you using to perform this mark all as read action?

  • The only account/label I have checked is my 'inbox', which is odd because it also shows me notifications for messages that skip my inbox.


    I have a gmail filter setup to for messages from some site to skip the inbox and apply a label, and yet checker plus is handling them as if they were in the inbox.


    To mark them as read I use the button on the grey bar on your popup. I think it says 'mark all as read' but I can't see it now because it disappears when there are no messages.

  • I wonder whether checker turns on the indicator because of those messages that are supposed to skip the inbox (maybe Google's API has them temporarily in the inbox before apply my filter), but then when I click 'mark all as read' it doesn't actually mark those messages as read because they are no longer in the inbox. I'll have to keep a closer eye on those (I get lots of them).

  • No, that last observation was a red herring. There is an issue there - it shouldn't be showing me those emails given that my filter causes them to "skip the inbox" but that is not related to the problem being discussed here.


    But I do have a new observation: the problem only happens when I clear list of messages in your popup via the main 'mark all as read' button. If I instead open the message(s) - indirectly causing them to be marked as read - then the problem does not occur.

  • ok that's a great clue, i'll queue this for investigation.

  • Having the same issues as Tom here as well. When will this be resolved. I see there has been no updates already for past 3 weeks. Top portion is when I try to delete the email and then recheck it again and the email still appears to be there when in reality it has been deleted when I go to the actual email through the website.


  • @Valeriy Nechayev are you using the mark all as read button like tom?

    And does this issue happen all the time or sometimes?

  • At Least a few times a day. I have tried that"mark all as read", and also deleting e-mails.

  • @Valeriy Nechayev Can you send me the background error logs next time it happens https://jasonsavard.com/wiki/Error_logs

  • I worked with you (see above) to isolate this bug - I'm disappointed it is still not addressed.


    The line above asks me to "contribute to encourage my support". I did contribute $20 and I've been quite patient, but this bug really ruins Checker Plus for me.


    (My contribution was about a year ago when I started using "checker plus for gmail" - it was to support it in general, not just to get my bug fixed.)

  • Sorry, I see that I had asked the only other user to report this issue a question about the logs, but they didn't respond, hence why I had not returned.


    I usually prioritize issues which affects many users, I've re-read the issue and it seems though it only comes up after performing "Mark all as read" - this process does take a few seconds to perform and may explain the visual delay. Can I assume if you perform the task, then wait a few seconds the badge will correctly show no emails?

  • No, it's kinda the opposite of that: when I use "mark all as read" the visual response is correct for a couple of seconds (the icon gets greyed out), but then the icon comes back on as if I had received new messages.


    If it were the way you described it it wouldn't bug me so much ;).


    In any event, I just wanted to let you know that I'm still out here waiting and hoping this issue will be addressed.

  • So I just tried replicating the issue and I couldn't. There might be some key differences between our setups. Would you be able to record a quick video of the issue? Perhaps even with your phone would work.

  • But I think we isolated it pretty well above (including console log). For me it is very consistent - it happens 100% of the time - but I guess that is because of my configuration.

  • (I don't think a video will tell you nearly as much as the investigation we did above.)

  • Actually from my experience, the video or screenshots tell me lots of info, to name a few: browser type, browser customizations, skins or themes, extension options, number of accounts, precise context in which actions are being taken.


    My extensions are fairly complex in the way you can interact with them so all this can help me narrow issue, and yes the logs help also.

  • Ok, here's a screen recording.

    Whoops. Too big, and not even close. I'm new to doing screen recordings and just discovered that Windows has a screen recorder built-in, which I just used. I tried a couple times and couldn't get close to 50MB.


    But this did make me aware of something: the time between when I click 'mark all as read' and the icon goes grey, and when it mistakenly goes back to red, is longer than I thought (hence the large MP4 files): it is probably about 40 seconds (I have 'real-time' polling).

  • Have you tried just the regular 30s polling to see if that makes a difference.

  • I don't remember all the things I tried - that was seven months ago. I could try it, but I wouldn't want to adopt it as a solution - I really prefer to use push.

  • I'm just looking to determine the cause of the issue and to replicate it on my side. Once that's done you can revert back.

  • Ok, I tried that - it makes the problem much more variable and minor.


    Sometimes the problem occurs, sometimes it doesn't. The time before the problem occurs now is quite variable, and the time before the problem corrects is tiny - just a second or two.


    If the problem was like this for me I wouldn't really think much of it and wouldn't report it - so maybe this is what it is like for lots of people?

  • ok good info, if you could again record the video and post it as unlisted on youtube or google drive and share it with me.

  • I did another video, and was reviewing it and discovered that the extensions' popup doesn't show up in the capture. No idea why, but all of my attempts were like that.


    So, I've resorted to using my phone (a Nokia 6.1 which has poor photo & video).


    I've now shared it with you via google photos. If I've used the wrong address or you need it to be via google drive then let me know.

  • I didn't receive the video, can you post the shared link here?

  • I'd rather not post a public link. What email address should I be sharing it to? I used the one I had "apps@jasonsavard.com". Just now added 'contact@' as well. As noted, this is in google photos.

  • excellent, I saw the video, ok that's good info, so the operation completes successfully, it's just the visual queue that's incorrect.


    Have you tried reinstalling the extension?


    I'm also curious if the issue happens if you simply mark the 2 emails individually as read (ie. not using the mark all as read button)

This website uses cookies to ensure you get the best experience on our website. More info
Got it!