Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Upload to Imgur not working

A couple days after installing the extension, I started getting an error message reading "Host might be down, please try another one..." every time I tried uploading a screenshot to Imgur. This has been going on for weeks, and Imgur obviously isn't down. In the Javascript console, I get the following error:
XMLHttpRequest cannot load http://api.imgur.com/2/upload.json. Received an invalid response. Origin 'chrome-extension://mdddabjhelpilpnpgondfmehhcplpiin' is therefore not allowed access. editor.html:1
  1. error imgur3: 404 - error common.js:27
This is happening on all my machines, with multiple ISPs, running a couple different versions of Chrome, on both Linux and Windows. Uninstalling and reinstalling fresh doesn't fix the problem.

Comments

  • Hmm it's still working for me, i'll see if others get this error in the next few days.
  • If there's any other debugging info you need, just let me know.
  • Yes this can help http://jasonsavard.com/wiki/Bug_form (and just ignore the logs since you did that one already thanks)
  • After a little digging, I discovered the problem was due to another extension of mine, HTTPS Everywhere, fighting with this extension. Adding an exception to HTTPS Everywhere for imgur.com solved the problem.
  • Hi,

    I'm having exactly the same issue. Reinstalling and disabling other extensions didn't help.

    Chrome 57.0.2987.98 but it also happens on  59.0.3042.4 Canary and Comodo Dragon.

    Windows 10

    Tried another Internet connection, still didn't work. I don't have another device to test it.

    Any suggestions?

    best regards, Matthew
  • @MateuszDorywalski Thanks for reporting it, I just opened a ticket with the Imgur team and pending their response.
  • Hi,

    thank you for the prompt reply, please inform me if you need any more information. I use this plugin all the time in my work and if there's anything I can do to assist in resolving this issue, I'm more than willing to help.

    best regards, Matthew
This website uses cookies to ensure you get the best experience on our website. More info
Got it!