Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Bug report: TypeError: Cannot read property 'push' of undefined

When using the Quick Add feature in the Chrome extension, after entering the calendar entry and hitting enter, the message in the thread title appears. Also, when I start typing again (to add a second calendar entry), the first entry data still appears and must be manually removed. This behavior started a couple of weeks ago.


Another minor note on this topic. In the scenario above, I often change the calendar for the entry to appear on when typing my first calendar entry. Prior to a couple of weeks ago, subsequent new calendar entries would retain that chosen calendar, until I navigated away from Calendar Checker. Now, the chosen calendar reverts to the default calendar each time. That behavior is undesirable for what I am doing, although I understand it may not be undesirable for other use cases.


I am on Calendar Checker 25.0.8.1, and Chrome 73.0.3683.86

Comments

  • edited about three weeks ago


  • ok good feedback for the remember your last calendar, i'm going to stick with the current behaviour because it seems that's how google calendar is doing it also, sorry.

    But inadvertently what probably caused this change was the addition of Option > General > Default calendar: where you can permanently set the default calendar.


    But more importantly is that bug, can you send me some screenshots or video to demonstrate it?

  • Yes, I understand that the "remember last calendar" behavior has changed likely due to Google change, and many prefer that. No problem at all.


    For the error message and the problem with the quick add not removing the previous entry, I now see that the problem only happens with one of my calendars. The problem calendar is a "G Suite" account calendar (not a normal Google account).


    For the problem, let me describe what I am doing in detail--


    I often enter several calendar entries in a row. To do that, I perform the following steps:


    -In Chrome, I click on the Checker Plus for Calendar icon, which opens the mini calendar.


    -I then start typing the details of the calendar item (e.g., "Dinner with Bob Apr 15") and hit enter. Normally a confirmation box appears in the lower left corner of the mini calendar. Now, the error message appears instead. Please note that the calendar entry does actually appear in my calendar, even though the error message appears.


    -To enter my second calendar entry, I simply start typing the second calendar item (e.g., "Dinner with Cathy Apr 17"). Prior to the problem I have noted, the new entry would appear in the entry box, and I could then hit enter. Since the noted problem has arisen, when I start typing the second calendar item, the text is appended to the end of the first entry (i.e. the first entry is not cleared). I will attach a screenshot of this.

  • edited about three weeks ago

    ok great info again, can you reproduce the problem, then keep the mini calendar popup window open and right click anywhere in the popup > Inspect > Console tab > Send me the logs (or take a screenshot of it)

  • I am not sure about sending these logs. Will the txt file I just sent work?

  • ok thanks for the logs,

    can you try double clicking the refresh button in the popup window and try adding just that first event again.

    the next test will be to try reinstalling the extension.

  • I double-clicked on the refresh button and tried adding an event. The problem remains.


    I saved my settings in Checker Plus, removed the extension, then added the extension. After loading my settings, I tried adding an event to the problem calendar.


    Success! Thanks so much. Sorry, I should have tried reinstalling the extension from the start. I appreciate your time.

This website uses cookies to ensure you get the best experience on our website. More info
Got it!