Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Customized notification sound not working in Firefox

I'm on Firefox 59 on macos High Sierra. Setting the notification sound for the Gmail checker does not seem to work. When i try to play a test notification, Firefox uses a different sound. I'm not sure where this sound is coming from as it's not one of the available sounds in your extension or the OS, perhaps it's a Firefox default sound. The volume controls do not work either. What's interesting is that the Calendar checker notification sound settings do work.

Comments

  • Did you try reinstalling the extension.
    Does it sound like the bell.ogg or chime.ogg from here https://jasonsavard.com/sounds/
  • No, it's not that sound. I believe it's whatever the default FF notification sound is, as other sites seem to trigger the same thing, even if the sound is overridden. I actually suspect it's because the sound property in the Notification api has been dropped in FF. https://developer.mozilla.org/en-US/docs/Web/API/notification/sound. Not sure if that's the property you're using to trigger this.

  • This "sounds" like a Firefox or system specific issue, excuse the pun ;)
    since you mention it happens with other sites.
    ps. i'm not using that api you mentioned but actually i'm using html5 audio
  • I'm having the same problem. The notification sound seems to be either the system or the default Firefox notification sound. I'm on OSX latest. On Chrome the sound is the correct "chime" as configured.


    The other thing is that on Chrome the notification buttons do not show up. Chrome/OSX notification screenshot attached. The screenshot for Firefox looks similar.


  • @GlennWaters Do you hear the correct sounds when you try changing them in the options?

    As for the buttons on OSX, Mac has decided to hide them under the more button, which appears when you hover over the notification.

  • Yes, the sound is correct when I change them in the options.

  • @GlennWaters I know in Chrome on PC you can disable the default sound for notifications in Windows. Can you browse around for something similar to disable on Firefox for OSX.


    windows example:



  • That seems to work, I have only tested one incoming email. The questions that remain...


    Why does this work for Chrome but requires the setting change for Firefox?


    More importantly, will this affect other Firefox notifications when the "play a sound" setting is turned off?


    FYI, on OSX, the setting to change is on the "Notifications" control panel. When that is open select the appropriate app and turn of sound. Screenshot attached.



  • edited about a month ago

    @GlennWaters Great discovery and thanks for the screenshot to help others.

    Essentially Firefox does not yet support the "silent" attribute for notifications from extensions.

    https://developer.chrome.com/apps/notifications

    Turning the sound off in Firefox will turn off the default sound for all Firefox notifications unless the process opening the notification has a sound of their own. ie. all my extensions :)

This website uses cookies to ensure you get the best experience on our website. More info
Got it!