Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

Outlook.com shows the side panel again

Outlook.com now shows the side panel on their site again. I just noticed it so it must be a recent change. Please fix it in your webmail ad blocker if you can. Thanks, David

Comments

  • Re-install the extension and reload outlook.com page.
  • Just tried it but it’s not working. Outlook has just changed its design a few hours ago and I think this is why it’s not working. I’m on the beta preview.
  • Can you send me a screenshot of this new new design? :) with the ad showing.
  • Of course, here it is: https://prnt.sc/gw95kg
  • Can you temporarily disable your other extensions (except mine) and reload the outlook page.
  • edited October 2017
    This was the first thing that I’ve tried. I have the following extensions: Adguard Adblocker, Ghostery, LastPass, Magic Actions for YouTube, Folx and yours. I’ve tried to disable them all but it’s the same except then I see the ads as well.
  • and if only my extension is enabled what do you see?
    I'm asking because the ad you see is actually a message saying that Outlook has detected an ad blocker...  but they haven't been detecting mine last I heard so I wonder what the message would be if only mine were enabled?
  • edited October 2017
    When only your extension is enabled then I see the ads and the side panel as well. If I enable the other extensions too then I don’t see the ads but I still see the side panel with this text. Until yesterday I couldn’t even see the side panel with your extension and it was brilliant but now I see the side panel as you can see on the screen shot. They have changed a few things that’s for sure because there are tiny things in the design which has been changed since last night.
  • With all the other extension disabled (your extension is still enabled): https://prnt.sc/gwa1e9
  • So the problem is they haven't updated my outlook account yet so it still works with mine. I would have to connect to your machine or borrow your credentials which I never do. So we'll have to wait till I can see this update.
  • edited October 2017
    I can send you the source code of the page because I know how to remove my content from the code. Let me know and I’ll do it shortly.
  • good thinking, but here's actual source i would need
    right click anywhere in the outlook page then "Inspect"
    then scroll to the top and right click on the <body> tag and copy > copy outerhtml and send that to me.


  • Okay, so here is a screen shot of the part of the code, this way I don’t have to remove anything. I hope this helps. You can see the side panel’s html in the black box. I’ve opened all the tags for you to see. Let me know if I can help you in any way. https://prnt.sc/gwa5y3
  • I just see that you posted what you exactly need. Now I have to go to sleep (I’m in Europe, it’s 1am) but I’ll do that tomorrow if the screen shot is not enough, just let me know.
  • great screenshot and precisely what i needed.
    ok you seem pretty good with the console
    can you do a search Ctrl+F when viewing the Console > Elements
    for the following strings, they should both come out only twice (except for css at the top which we can ignore) hope you understand this, but I want to make sure going forth i blindly push an update to hide the new elements that i'm not accidentally hiding other elements.

    _2KxiN0IH0mUjw-Bw6WdAoB
    _2deFj-S8jd1C_MSRZoRvlY
  • edited October 2017
    That’s correct, both classes can be found twice only in the html. They come up much more times in the css but I guess that’s not what you need. Both classes come up in the section that I’ve sent the screenshot about so precisely in the side panel part.
  • are you free today if i do a quick push to test this out? like in the next hours?
  • Yes, but I may won’t be available between 6pm and 7pm CET. It’s 4.36pm at the moment.
  • i realize the timing is bad but the push was slow, as soon as you have time let me know about this...

    re-install the extension to force v5.0.5.2 and reload the outlook page and let me know if it works and nothing was impacted, some tests to run:
    -Compose an email
    -View emails from different folders
    -Click the settings button at the top right (beside the '?' mark)
  • edited October 2017
    Perfect! Thank you Jason. Now it works just like before. I tested with all the folders, new message, settings icon, everything.
  • edited October 2017
    Hi Jason, I have the same problem. I already appeared to have v5.0.5.2, but I removed it and restarted the browser and reinstalled anyway, but I still have the ad blocker message on the side of outlook.com webmail. Here is a sccreenshot showing the console. I note that the class for the section of html in question is identical to the one you are discussing in this thread.



    Thanks for your time and any assistance you can offer.

    If I edit the css to display: none; from display: flex; the pannel disappears and does not appear to have any obvious negative effect, I imagine that your browser extension does something similar on page load?
  • edited October 2017
    @PaulH You are quite right, once small difference is that you are on Firefox and I have not pushed this fix there quite yet (I know the versions are the same but the code is different that's my fault)
    I'm going to wait another few days to double verify there is no adverse affect to my change and then update the Firefox extension.
  • Fair enough, thanks for your prompt reply.

    I'll just kock up a Greecemonkey script in the meanwhile.
  • Just want to thank you Jason for your awesome work and continuing support.
    Just saw the same grey box starting today ( Sat Oct 14 ) and uninstalled and reinstalled your update on Chrome and it worked. You Rock !
This website uses cookies to ensure you get the best experience on our website. More info
Got it!