Extensions Blog Press Contribute Forum FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support About
Forum FAQ Videos Changelog Bio Contact

Effectively no way to block calendar notifications if you want to keep your calendar page open

I believe you are aware of this limitation based on your suggestions.  If one keeps calendar open, which I wan too, then if you disable the duplicative alert your forced into interruptive notifications.  Any suggestions or plans to create a solution?

Disable Google Calender's website popups

If you are getting Google Calendar notifications:

  • Click the settings button in the notification to disable them. (Make sure it's a Google Calendar notification and not my extension's notification :)

If you are getting interruptive alerts:

  • Just close your Google Calendar's web page and the interruptive pop-ups won't occur.


Note: Google Calendar's notifications are very basic and they have no quick actions like snooze etc. that's why I created my extension :)

«1

Comments

  • edited March 2017
    Good news, I just investigated it further and found a solution and started rolling it out today :)
    More info https://jasonsavard.com/wiki/Checker_Plus_for_Google_Calendar_changelog
  • Awesome - thanks!
  • Just configured and it stops the interuptive portion - the most important part. However you still see the message to snooze for 5 min on the top of calendar page..Be awesome if that could be stopped/prevented too?

  • glad it's working and thanks for reaching out, i'll wait for more feedback about that message, perhaps some will like it there.
  • doubt it..kind of pointless if one is using your reminders..just noise
  • new issue. works well on pc1 but on pc2, where I got the update a few days later and have configured the same as PC1 I'm still getting the interruptive alert & message (as if you extension setting is doing nothing) whereas on PC1 I just get the message at the top of calendar per our earlier discussion
  • Re-install the extension, set the option in the notifications and re-open any google calendar tabs
  • Will it remember all my setting or do I have note those first or is there an export & import 
  • can't promise you that, sorry, it's finicky when re-installing to a different version, but you can let me know.
  • can is use save options then load options to export settings and import settings?
  • give it a try and let me know what happens.
  • just reinstalled, can u turn on my advanced/contributed options please
  • never mind figured it out

  • and reinstall fixed - thanks.

  • FYI I push my updates incrementally to a certain portion of the users for testing, in the future you could just wait for it to arrive without the hassle of re-installing the extension etc.

    ps. We're you prompted to load your previous settings?
  • I did wait for both and this one was a few days later..no.

    All below is mean to be constructive criticism; don't take the wrong way
    i did save and load didn't work and is confusing...needs polish..really needs to work to make the troubleshooting step of uninstalling and reinstalling crisp..also authorizing my google account to re-enable "purchase" feature, etc is a little kludge
  • Interesting..when I got open had the welcome page and then prompted to restore settings - and went smoothly - but wrong PC.  The Home box was fine and no need to change anything. This reminds when the setting restored failed on the problem PC it thur an erroneous error about not being logged into my google account, which was false..
  • The issue is back..getting interruptive alerts again...I have this unchecked and I assume that is what you mean by "remove" in: Go to Google Calendar's options: 

     > Settings and remove this option:

    Notifications: Use browser notifications instead of interruptive alerts
  • what changed since the last time?
    did you restart your chrome?
    did you sign out?
    did you re-install the extension?
    did you change any calendar or extensions settings?
    ...just looking for a lead
  • Added 3 extensions I'm considering about 2 hours ago:
    Too Many Tabs - just got rid of
    Tab Wrangler
    The Great Suspender
  • edited April 2017
    Can you verify if this extension option is still checked?


  • ok another test, can you uncheck that extension option and then recheck
    and let me know if there is a permission box that appears. if so click accept.
  • no permission box, just the Did you also disable Google Calendar's notifications? box
  • ok can you reload the google calendar tab and do a test again.
    it should be as easy as creating an event for 1 minute into the future.
  • same problem
  • Can you send me a screenshot of your google calendar tab is presenting the dialog?
    also the url at the top
    and lastly can you right click on the calendar page > Inspect > Console tab > and let me know if you see "preventAlerts.js" show up.


  • will do, what do you mean by "...of your google calendar tab is presenting the dialog?"
  • you said "The issue is back..getting interruptive alerts again"
    can you specify where you are getting these alerts, which context? can you send me a screenshot?
This website uses cookies to ensure you get the best experience on our website. More info
Got it!