Extensions Blog Press Contribute Support FAQ Videos Changelog About Contact English Dark mode
Chrome extensions you can't live without!
Extensions Blog Press Contribute Support FAQ Videos About Contact

"Recent Tabs"-extension is listening for @ input

edited June 2016 in General
First of all: I have been using and enjoying the "Recent Tabs" chrome extension for a very long time already. I've been coming from Opera where the "Recent Tabs"-feature was build-in to the browser and I got so used to it that I needed it in Chrome, too. Thank you very much for crafting that extension.

For years, I have the following problem with the extension and, I think, it's finally time to get to solve it.

Background: I am using Ctrl + Q as the keyboard shortcut to switch to the recent tab. It is the *best* key to do this as it is near Ctrl + Tab, Ctrl + W, Ctrl + R and Ctrl + T. On my German keyboard Q is also the button to write the @ symbol. The @ symbol can be input by pressing Ctrl + Alt + Q or with AltGr + Q.

Problem: Switching the tabs with Ctrl + Q works very well but *every time, every time* I need to write an @ in Chrome, the "Recent Tabs"-extension also switches to the most recent tab which, obviously, is very annoying - especially when inputting email addresses.

Troubleshooting:
#1 Approach: I am a AutoHotKey-user and tried to circumvent the problem by sending my or other email addresses I type a lot through AHK with the following script.

#<::
Send xxx@xxx.xxx
return

Outcome: When using the keyboard shortcut of the above AHK script, the "Recent Tabs"-extension still switches to the most recent tab.

#2 Approach: I created and am using the following AHK script to send an @ by pressing CapsLock + Q.

SetCapsLockState, AlwaysOff ; always disable the CapsLock key

Capslock & q::
return

Outcome: When using the keyboard shortcut of the above AHK script (CapsLock + Q), the "Recent Tabs"-extension still switches to the most recent tab.

Generally, I find it confusing that the "Recent Tabs"-extension is even listening for an @ input as I only set it to listen to Ctrl + Q.

I have been living with this for ages and I'd be grateful if there was finally a solution to this problem. Thank you very much in advance.

Comments

  • Yeah even I have given up on the Usage #2 method, refer to the extension options I recommend usage #1 instead which does not fail ever.
  • Usage #1: Go to Chrome menu > Tools > Extensions and then scroll to the bottom and find Keyboard shortcuts then under Recent Tabs assign the key of your choice.

    That is how I am using Recent Tabs, still it always switches to the most recent tab if I input an @ in Chrome in all of cases listed in my previous post. Until now, troubleshooting has not helped...
  • Did you disable option #2 ?... 

  • Incredible! No, I didn't have option #2 disabled. I disabled it and when inputting an @ now, Recent Tabs does not switch tabs anymore. I tried to solve and lived with this issue for so long and the solution was so easy?! :D

    Anyway, thank you so much! Your help is greatly appreciated!
This website uses cookies to ensure you get the best experience on our website. More info
Got it!